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UNIT-II 

Styling Shapes 

By this point you’ve had some time to interact and become more familiar with the Sketch interface. 

This chapter focuses on the shapes that you can create with Sketch. Shapes are the most important 

layers that you will use in Sketch, and every design you create in Sketch will be made of shapes that 

you choose from the Insert menu. They are the building blocks of any design that you will work on in 

Sketch. 

As mentioned in the Chapter 2, you can use the Insert tool from the menu to add shapes to your 

canvas, or you can draw them directly onto your canvas using your mouse, trackpad, or graphics 

tablet. There are eight different kinds of shapes that can be created within Sketch: lines, arrows, 

rectangles, ovals, rounded rectangles, stars, polygons, and triangles. All of these options can be found 

in the Insert ➤ Shape menu, as shown in Figure 3-1. With these shapes, you can pretty much create 

anything. 

 

Figure 3-1. Clicking Insert ➤ Shape on the toolbar provides a list of preset shapes that are available within Sketch 
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Once you select what shape you want, simply click and drag your mouse anywhere on your canvas 

that you want your shape to appear. Sketch will begin to create that shape with the default color 

(usually light gray for the fill and a darker gray for the border). When you release the mouse button, 

your fully formed shape will be complete and on the canvas. You will also notice that the Layers list 

will be updated to reflect the name of the layer (usually the name of the shape and the number 1 for 

starters). The numbers will increase in increments of one as you continue to add unnamed layers. As 

long as the shape is selected, the Inspector will also update to show you the properties associated with 

your shape. Pay particular attention to the values in Position, Size, Opacity, Fills, and Borders. If you 

change or edit any of these values in the Inspector, Sketch will automatically update the shape to 

reflect these changes. 

 

Special Shapes 
Some of these shapes have special settings in the Inspector. For example, the rounded rectangle shape 

will have additional Inspector settings for editing its corner radius. Setting the radius to 0 will yield 

no rounded corners and create a square, while the maximum setting of 40 will yield a rectangle with 

very rounded corners. 
 

 
The star shape will have additional settings: a radius and a point setting become available in the 

Inspector, which will automatically update the number of points on the star as well as the center 

radius of that shape. The radius of the star refers to the distance from the center of the star. The 

points refer to the number of points on the star. The default point setting for the star, however, is 5. 

Changing the point setting to the maximum of 50 will increase the 

number of points on the star. The radius in Figure 3-2 is set to 50 percent, and the number of points is set to 

10. 

 
 

Figure 3-2. A 10-point star with a 50-percent radius 
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The polygon shape also has a point setting that will allow you to change the number of points 

from the default of 5 to a maximum of 10. 

 

Editing Points on Shapes 
To understand shapes fully, you must also understand points. Points are the basic elements of shapes. 

That is to say, points make up shapes. The line that connects two points is called a path. Thus paths 

combine two points to create shapes. A shape, then, is a collection of paths on a point. 

Sketch also lets you edit the points of existing shapes on a canvas. After drawing your shape, select it 

and you will see the white handles that allow you to transform the shape. These handles, located at the 

top, bottom, and corners of the shapes, allow you to adjust the size of each shape manually. Adjusting 

these handles will increase or decrease the size of the shape in height and width accordingly. 

Adjusting the handles at the corners of a shape will alter both height and width. 

But what if in the course of your work you find that you’d like to move the actual points in 

shapes to change them? Simply double-click the shape. You will notice the handles disappear and 

that they change to points. There will be multiple points depending on the 

shape. The Pen tool will also appear on your canvas when you hover your mouse over the intersection 

points of the shape, as shown in Figure 3-3. 

 
 

Figure 3-3. Double-clicking a shape will let you adjust the points. Note the Bezier curves in the Inspector 

 

This will allow you to edit the shape’s points based on the tool that you select in the Inspector on the 

right. You will also notice that once the shape’s points become editable, four new selections will 

appear in the Inspector as well. These four different modes allow you to manipulate those points in 

various ways. These modes are: Straight, Mirrored, Disconnected, and Asymmetric. In Figure 3-4, the 

triangle from Figure 3-3 has been adjusted using the Mirrored Bezier curve. 
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Figure 3-4. A triangle shape’s points are edited using the Mirrored mode tool 

 

Straight Mode 
The Straight tool allows you to edit a path along a straight line with no handles or curves along the 

control point. 

Mirrored Mode 

This mode provides two opposite and mirrored points that appear the same distance from the main 

point and at the same angle. Sketch will remove any corners along the shape. 

 

Disconnected Mode 
This mode creates two points that are independent of each other. You can change each handle’s point 

without affecting the other. 

 

Asymmetric Mode 

This mode is similar to Mirrored mode, but the distance between the main point and the control 

point will be independent. 

Once you have made the points editable, you can click anywhere on that line between any two points 

to create a new editing point, and so forth. 
 

 

Combined Shapes 
There will be times when Sketch’s ready-made shapes aren’t exactly what you need in your designs, 
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and it is necessary to combine shapes to get what you want. Sketch lets you to combine shapes to 

create unique forms that aren’t included right out of the box, or that aren’t immediately available, 

using the Insert menu. You can do this by dragging a shape on top or over another, selecting them 

both with your mouse, and clicking Union in the toolbar. Doing this will combine both shapes. Once 

they have been combined, as shown in Figure 3-5, they will behave as one solid unit. 

 

Figure 3-5. A triangle and a rounded rectangle before and after being combined by using the Union button 

 

Custom Shapes 
Sketch also makes this easy to create your very own custom shapes. Go to Insert ➤ Vector from the 

toolbar. The pointer will turn into a Pen tool. You can use this tool to create custom lines and custom 

points. You can click anywhere on your canvas to create multiple points for your custom shape. 

You can also use the Transform tool to distort your shapes by changing its points. When using the 

Transform tool on a shape, you will notice that the opposite side will always move in tandem and 

in the opposite direction. The Transform tool is often used to create a perspective view of 

rectangular or square shapes. It has, however, a more flattening effect on circles and ovals. 

 

 

 

Boolean Operations 
There will be times while designing when you need to create a custom shape. Further, it might 

be a bit of a challenge to create some unique shapes using the vector tool. 

Sometimes, it is only possible to create this unique shape by combining two existing shapes in a 

unique way. This is the perfect opportunity to learn about another one of Sketch’s handy features 

called Boolean Operations. 

Boolean Operators are available in many graphics programs, including Photoshop. Thus if you’re 

fairly adept at Photoshop, you should be familiar with the term Boolean Operators and what it 

means. For those of you who are not Photoshop users, a simple way of thinking about Boolean 

Operators when it comes to design software is that they allow you to create more complex shapes 

that consist of multiple paths. They allow you to group multiple paths together into more complex 

paths upon which Boolean Operators can be implemented. 

Boolean terms are represented in the Sketch toolbar by buttons that have been conveniently grouped 

together in their own section, as illustrated in Figure 3-6. They represent actions that can be taken 
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when using two or more shapes that must interact with each other in a specific way. Simply put, these 

actions include Add, Subtract, Intersect, and Difference. All four of these tasks govern specific 

interactions among particular layers, shapes, and paths. 

 

Figure 3-6. Boolean Operator buttons in the Sketch toolbar 

 similar concept applies to Sketch. The icons associated with these buttons, as well as the manner in 

which they are grouped in the toolbar, are great indicators as to their use. To 

illustrate the effects of Boolean Operators, we will begin with two circle shapes, side by side, one 

slightly overlapping the other, as shown in Figure 3-7. We will then select both shapes by holding 

down the Shift key and selecting each shape, or by dragging a container around both shapes. You 

should see handles around each shape. 

 

 
Figure 3-7. Two slightly overlapping circles illustrate the various Boolean Operators in Sketch. Note that both are selected 

 

Union 
The Union tool combines any two shapes. To use to the Union tool, select both shapes. Then click 

the Union button in the toolbar. As the image and its name implies, both shapes will be merged 

together to create one new shape. As shown in Figure 3-8, the new shape will have properties of both 

shapes. Nonetheless, you will still be able to edit both shapes individually if you so desire. 
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Figure 3-8. The effect of the Union Boolean Operator on our two demonstration circles. Both shapes have been merged into one new 

shape 

 

 

Subtract 
The Subtract tool will mask an area of overlapping shapes, thereby creating a new shape that is the 

result of the shape on top being removed from the one underneath it. Since our bright red circle 

was overlapping the darker red circle, it has been subtracted from the resulting shape. What 

remains now is the darker red circle minus the area where it overlapped with the other, as seen in 

Figure 3-9. 

 
 

Figure 3-9. The effect of the Subtract Boolean Operator on two overlapping circles 
 

Intersect 
The Intersect tool highlights the negative space between two overlapping shapes to result in one 



 Ms.R.KAVIPRIYA, DEPARTMENT OF COMPUTER APPLICATIONS
 

 

 

 

 

new shape. Thus it appears that our two circles have disappeared, leaving only the space they both 

shared. What remains is created by the space where the two previously overlapped, as shown in 

Figure 3-10. 

 

 

 

 
Figure 3-10. The resulting shape when using the Intersect Boolean Operator on two overlapping circles 

 

Difference 
The Difference tool highlights the negative space between two overlapping shapes as well, but 

displays the opposite effect of the Intersect tool. The resulting shape is shown in Figure 3-11. 

 

 

Figure 3-11. The resulting shape when the Difference tool is applied two adjoining circles 
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Masks 
Masking is a feature that can sometimes present issues for new designers. Masks in Sketch are a great 

way to add a unique element to an otherwise drab design. Masks are shapes that other objects can fit 

within. The great thing about masks is that you can use pretty much any shape to make a mask. You 

can use a mask, for instance, if you want an image to 

appear as though its outline has been carved into a certain shape, like a star or a circle. In so doing, that 

shape dictates the shape of the mask and, ultimately, how the masked image will appear. This kind of 

mask is known as an Outline mask. 

When applying a mask to your canvas, every layer and shape in the selected group will be affected 

by that masking effect. Therefore, if you are attempting to mask specific layers but not others, it is 

best to move those layers out of a group. 

For example, in Figure 3-12, you will see three items on the canvas. When a mask is applied by going 

to the Layer menu and selecting Use as Mask from the drop-down, all of the items except for the one 

that is selected “disappear” from view. 

 
 

Figure 3-12. Selecting Use as Mask from the Layer menu lets you use one shape to mask othersest assured they haven’t gone 

far. Sketch is applying the mask effect to everything on top of the image to be used as a mask. 

When this happens, they disappear. However, a quick check of the Layers list will show you that 

they are still on the canvas in their original 
positions. The Layers list will also indicate specifically which layers have had a mask applied to them 

with a small bullet to the left of the layer name. 

Hovering your mouse over the layer will highlight the shape on the canvas. If you have a layer that is in 

the mask group but that you don’t want to be affected by the mask, simply select it, go back to the 

Layer menu, and click Ignore Underlying Mask. You should then be able to see the shape without the 

effect of the mask, and the bullet will disappear from that layer. 

 

Outline Mask 
To see the masking effect in action, simply drag your new shape over the mask shape, as shown in 
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Figure 3-13. You will see that a star mask has been applied to the image on the screen. The parts of 

the image that fall outside of the star will not be shown. 

 
 

Figure 3-13. A masked image with the star shape 

 

 

Alpha Mask 
An Alpha mask allows you to apply a gradient effect as a mask. It works in the same way as the Outline 

mask. To see this effect, you need to select Alpha mask from your Layer drop- down, and you will need 

to edit the color gradient and settings in the Inspector at the right, since the gradient is what determines 

the fill, as opposed to the shape in the Outline mask. You can then adjust the transparency and select 

the appropriate gradient setting, depending on the effect that you would like to create. 

Flattening 
Flattening is the process by which you remove the hierarchy of paths and sub-paths that make up a 

shape. If you are familiar with other graphics programs, you may have gotten into the habit of 

flattening layers to reduce file size and possibly to improve performance, since large file sizes tend to 

slow down a computer. Sketch is no different in this respect. Multiple pages, artboards, and effects 

can slow things down significantly. However, if you have a number of shapes that consist of more 

than just a few sub-paths and intersects, it can be a good idea to flatten them in order to keep them as 

clean and consistent as possible, and it’s just good design to do so. Flattening will remove extraneous 

vector points and Bezier curves and make your exported file smaller as well. 

 

Scaling 
Scaling in Sketch happens in two very distinct ways. Let’s discuss them both since they will 

produce very different results on your shapes. If you have a particular shape on your 

canvas, arguably the easiest way to scale that shape up to make a bigger shape is to select and drag 

the handles of the shape to your desired size. You will notice that the dimensions in the Inspector 

will also adjust automatically as you are adjusting the corners of the shape. However, if you have a 

shape with an outline or effect attached to it, then dragging to scale will only increase the overall size 

of the total image. The actual border and any additional associated effects will not increase in a way 

that is proportional to the image. If that is your overall desired effect, then it is fine. However, if it is 

not, you might be wondering how to change this. 
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If you’d like to scale the shape as well as its associated effects (including borders, shadows, and other 

effects), then you will need to use the Scale function. 

You can access the Scale function from the toolbar by clicking the Scale button. Once you’ve 

selected it, a window appears which allows you to change the dimensions of your shape. The 

window contains editable fields (height, width, and scale) which allow you to change their values, 

thus scaling the layer appropriately. 

Figure 3-14 shows three green rectangles that I created on my canvas. From left to right, the first 

rectangle is the original. The second (center) was created by dragging the handles to create a 

rectangle that is roughly twice the size of the original. The third rectangle (right) was created using 

the Scale function and increasing the scale size from 100 to 200 percent. Note the difference between 

the second and third rectangles. The border around the third rectangle has increased proportionally to 

the size of the shape, whereas the border around the center rectangle is the same size as the original, 

even though the size of the rectangle has increased. 
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Figure 3-14. Sketch’s scaling feature in action 

 

Styles 
Now that you’ve learned about the interface and styling, we’ll dive a little deeper into details and 

functionality of the Inspector and attaching various styles to the shapes and layers in your designs. 

Your designs will likely consist of images and shapes. They will also, naturally, contain a variety of 

fills and borders, so we’ll start with these. 

 

Fills 
While we briefly touched upon the fill feature in our earlier discussion of the Inspector, we will now 

explore this feature in greater detail. As mentioned earlier, most styling will take place in the 

Inspector, which is located on the right side of the Sketch canvas. Fill has a few additional properties 

associated with it. Specifically, when you have created a shape on your canvas, you can easily change 

the fill attribute by ensuring that the check mark next to the fill attribute is checked, and by clicking 

the default gray swatch next to it. This will reveal 

the color picker, which allows you to select pretty much any color in the spectrum as the fill color for 

the selected shape on your canvas. The shape then updates automatically with a solid color if none of 

the other selections have been activated. 

There are other types of fills, of course, and they all appear as options for styling your layer once you 

select a fill and reveal the color picker pop-up. Beyond Solid Fill, there is Linear Gradient, Radial 

Gradient, Circular Gradient, Pattern Fill, and Noise Fill, as shown from left to right in Figure 3-15. An 

explanation of each type of gradient follows. 
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Figure 3-15. A Pattern Fill style on an oval 

 
 

Pattern Fill 

This feature allows you to use an image or selection with a pattern as a fill. It’s a nice way to give 

your design some texture. Sketch also comes with some preset textures that you can use in your 

design. An illustration of a Pattern Fill style is shown in Figure 3-15. 

 
Noise Fill 

An illustration of a Noise Fill style is shown in Figure 3-16. 

 

Figure 3-16. Noise Pattern Fill on an oval 
 

Sketch allows you to add multiple levels of fills, and it also allows you to combine fills, colors, and 

gradients all on the same layer. 

Now notice in Figure 3-17 that on the bottom of the pop-over in the Inspector Panel, there is a 

row of fields. From left to right, they should read Hex, R, G, B, A. Hex stands for hexadecimal 

code, which is a numerical representation of color in HTML and CSS. Every 

color has a different Hex code. The field above the word Hex is where Sketch allows you to enter the 

Hex code of a particular color instead of using the color picker. The letters stand for the colors Red, 

Green, and Blue. The letters below the color picker also let you know that Sketch is in RGB mode. 
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Figure 3-17. Inspector with fill attribute pop-over extended to reveal saved swatches, Hex codes, color picker, blending, 

opacity options, and gradients 

 
Sometimes, you may see the letters H, S, and B below the color picker instead, as is shown in Figure 

3-17. H, S, and B stand for Hue, Saturation, and Brightness, respectively. 

If you move your cursor around within the color picker, you will notice that the values in the fields 

below (R, G, B or H, S, B) will change, as will the Hex code. If you are in HSB mode, moving the 

pointer towards the top increases the brightness, and moving the pointer left to right increases the 

saturation. Typically, you will want to be in HSB mode for designs. 
 

You can also save color swatches that you use often or plan to use in the future. Sketch 

automatically allows you to save color swatches right below the color picker by clicking the plus (+) 

sign at the lower-right corner of the color picker window. Sketch will also let you save a color 

swatch via the Eyedropper tool. This lets you select a color from anywhere on your screen, even 

outside the program. 

 

Gradients 
Gradients are a kind of fill that transition from one color to another. When using the Gradient tool, 

Sketch will show you the points of transition, which are editable right on your canvas. 

 
Linear Gradient 
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As its name suggests, the Linear Gradient tool allows you to create a gradual blend from one color to 

another along a straight line. If you select this gradient, you will see two editable points in your layer 

in the canvas. Dragging each point will adjust the points on the gradient. You can also use the 

gradient bar in the Inspector to adjust points in your gradient. You may add points along the line as 

well simply by clicking anywhere along the line. Each point will represent a color stop of the gradient 

in your layer. These points allow you to edit and adjust the smoothness of the gradient on your layer. 

To delete a stop on the line, hit the Delete button. The Linear Gradient style is shown in Figure 3-18. 

 
 

Figure 3-18. Linear gradient style 

 

Radial Gradient 

The Radial Gradient tool adds a larger circle to your layer. Within this larger circle, there will be two 

points: one in the center that sets the center of the radius, and the other outside of the radius, which 

controls its size. The Radial Gradient tool transitions from one color to another using a circular 

pattern or motion. You can expand the radius and shape of your gradient within the canvas as well. 

The Radial Gradient tool is shown in Figure 3-19. 

 

Circular Gradient 

The Circular Gradient tool transitions clockwise around the center point of your layer. The Circular 

Gradient tool is shown in Figure 3-20. 
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Figure 3-20. The Circular Gradient tool 

 

Angular Gradient 

The Angular Gradient tool transitions from one color to another in a counterclockwise 

direction around a specific point. 

Blending 
There are a number of different blending options available in Sketch. To see them all, you will need to 

click the fields above the blending option. A drop-down menu shows you a list of all of the blending 

options available for the selected shape. 

 

Opacity 
The opacity setting in Sketch is layer specific, meaning that each layer can have not only its own fill 

style and setting, but it can also have a different layer of opacity. You can adjust the level of opacity 

for the corresponding layer by clicking the number and adjusting the number (in percent) above the 

Opacity label. 

One of the great things about Sketch is the ability to add a number of effects to the same layer. Thus 

you can add as many fills to one layer as you choose. They will stack up on top of each other from 

bottom to top. To add a fill, simply hit the + button to the right of the fill section in the Inspector. 

 

Shadows 
Shadows are great in designs because they can make your designs more three dimensional. Even if you 

are working on a flat design, a shadow can help make certain items in your design more pronounced. 

And even in a flat design, you must consider elements such as light and angles, which make some 

elements actually need a shadow—even if it’s subtle. 

While flat design specifically did away with the dreaded “drop shadow,” lately the trend of using 

long, flat shadows in a flat design has become popular. This effect adds depth while still maintaining 

the “Flat” effect. For the most part, though, you will likely be using shadows minimally in your 
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designs, specifically when designing for iOS. 

Sketch has shadow settings that you will find in the Inspector that are pretty typical for graphics 

programs. You can change the settings for where your shadow appears on the x or y axis, the blur, and 

the spread. The same settings apply to the inner shadows as well. 
 

 

Blurs 
Sketch has four different modes for the Blurring effect: Gaussian Blur, Motion Blur, Zoom Blur, and 

Background Blur. We will now discuss them in and will show you examples of a few of these blurs. 

Gaussian Blur 

The Gaussian Blur is a staple of most graphics programs, and it is used to reduce noise in an image as 

well as detail. The effect is an even, smooth blur across the affected layer— typically an image. The 

Gaussian Blur effect and all other blurs can be found at the lower- right corner of the Inspector. It is 

the first selection on the list of additional blur effects available in Sketch. You can adjust the amount 

of the blur in pixels using the provided slider, which appears when you select this effect. Figure 3-21 

shows the original image on the left and the same image with the Gaussian Blur effect applied at 4 

px. 

 

Figure 3-21. Original image on the left and the same image with the Gaussian Blur effect applied at 4 px 

 

Motion Blur 

As its name implies, the Motion Blur produces the effect of something that is in motion. This effect 

will allow you to blur in a particular direction. As with the Gaussian Blur, you can adjust the amount 

of the motion in pixels using the provided slider once you select this effect from the drop-down. You 

can also adjust the angle of the blur using the dial that appears once this option has been selected. The 

Motion Blur effect is illustrated in Figure 3-22. 
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Figure 3-22. Original image on the left with a Motion Blur effect applied on the right 

 

Zoom Blur 
The Zoom Blur effect lets you blur a layer from a specified point outward. Once you select this blur, 

Sketch will present you with options to edit the point from which the blur will originate as well as 

the amount of pixels. The Zoom Blur effect is illustrated in Figure 3-23. 

 

Figure 3-23. A standard image on the left with no effect applied, and the same image on the right with the Zoom Blur effect 

applied 
 

Background Blur 
The Background Blur effect was added by the Bohemian Coding team specifically after the iOS7 

redesign. It is an effect that is used liberally throughout iOS, so you should feel comfortable about 

using it in your app designs. It blurs the background behind a shape but not the shape itself. The 

effect works best once you have reduced the opacity on the intended layer. Without this, the effect 

will be difficult to see. 
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The Background Blur effect will take a considerable toll on your computer’s resources. You will see it 

slow down the program and your computer overall. Thus it’s wise to use it sparingly. 
 

 

Sharing Styles 
At some point in your design experience, you will want to apply the same styles (shadows, fills, and 

so on) to a particular shape or object. With Sketch, this is possible to do in a few easy steps. But first, 

why would you want to do this? As a UI designer, you understand that speed and efficiency are 

paramount when designing interfaces. You will undoubtedly find yourself in a situation where both 

will come into play, and you will be required to be not only a skillful designer, but a fast and efficient 

one as well. 

Sharing styles will help you with this. Consider for instance when you have a shape to which you have 

attached certain styles and you need to attach the same style or style to a different shape. First you can 

copy a style from one object to another by using the option+ +c key combination. This copies a style 

from one object. Then navigate to the new object, select 

it, and press the option+ +v key combination to attach the style to the new object. Note that this 

simply copies the style from one object to another. The objects, however, remain independent of 

each other. 

If for some reason you need to share a style among multiple objects, you would then use the Sketch 

Shared Style function. This allows you to create a new style and attribute it to any new object or 

objects. The great thing about this feature is that once you create a style and attach it to an object, any 

additional changes to the style will update all objects to which it has been attached. 

To create a new style, simply click the drop-down in the Inspector that reads No Shared Style, as 

shown in Figure 3-24. You can create a new shared style here, and it will automatically be 

associated with the selected object. 
 

Figure 3-24. Creating a shared style by clicking the Shared Styles drop-down in the Inspector 

 

Figure 3-25 shows two images side by side. One oval has a style attached to it and the other does not. 

To attach the style to the new oval, you must select the oval and the desired style from the style drop-

down in the Inspector. The oval will automatically be updated 

with the new style and any additional changes moving forward, also as shown in the figure. The 

styles can be updated, deleted, or changed at any time. As long as a style has been attributed to an 
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object, they will be updated with that new style. 

 

Figure 3-25. Two objects with a single style being updated 

 

Images 
As mentioned in the very first chapter of this book, Sketch is primarily for designers who want to 

create user interfaces for the Web and for mobile devices. Because it allows designers to work 

with vectors, Sketch is likely not the best option for image editing. 

As mentioned earlier, that was the initial purpose of Photoshop. Thus, in this instance, I recommend using 

it or any one of the other worthy alternatives when you need to do serious image editing. 

That being said, there are some fairly decent basic image editing tools in Sketch if you need to do 

something related to images on the fly. 
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Sketch has improved its image editing abilities (specifically for bitmaps) with version 3.X, and it has 

increased the number of image editing tools. The image editing tools are activated when you select an 

image or bitmap on the canvas and double-click it. You will notice that the Inspector updates to 

include tools that are specific to image editing. A selected image with the image editing tools on 

display is shown in Figure 3-26. 

 
 

Figure 3-26. The new and improved bitmap editing tools in Sketch 

 
The tools available for editing bitmaps are as follows: 

Selection: This tool allows you to select a rectangular area anywhere on your image. 

Magic Wand: This tool lets you select an area within an image by clicking and 

dragging. 

Invert: This tool lets you invert any previous selection. 

Crop: This tool lets you select an area of your image and exclude anything outside 

of the selected area. 

Color: This tool lets you select an area and fill it with any color selected from the 

available color picker. 

Vectorize: This tool will turn a selected area into a shaper layer of its own. 
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Color Adjust 
While Sketch’s ability to edit photos is limited, you can still do some minor adjustments. If you 

need to adjust colors of an image or bitmap, Sketch allows you to adjust the Hue, Saturation, 

Contrast, and Brightness of an image by moving sliders in the Color Adjust panel, which is 

shown in Figure 3-27. Once your image has been imported, click the box 

next to the Color Adjust heading in the lower-right corner of the Inspector, which will bring up the 

Color Adjust sliders. 

 
 

Figure 3-27. An image altered using the Color Adjust tool 

 

Styling shapes is an important part of designing with Sketch, giving your designs character and your 

own unique touch. Take some time to become familiar with each style—and there are many—to 

understand how they can enhance your work. Experiment, mix, and match where you can. 

 

Summary 
Shapes are the building blocks of almost any design, and now that you understand how you can 

customize your shapes by using the available effects and styles, you are well on your way. Take some 

time to experiment with the styles and features that you’ve just learned about before you move on to 

the next chapter. 

In the next chapter, we will cover symbols and text, which will add a new exciting dimension to your 

designs. 
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Symbols and Text 

In the previous chapter, you learned about sharing styles between objects, and you used the 

option+ +c and option+ +v keyboard combinations to copy and paste styles between them. This is 

a helpful and simple way to share styles between multiple objects. In this chapter, we will discuss 

Symbols, a Sketch 3 feature that takes sharing styles to a whole new level and that will greatly 

improve your workflow. 

Symbols are new to Sketch 3, and it was one of the features that designers were most excited about in 

the new release. The Symbols feature allows you to select and reuse groups of objects across pages and 

even artboards in your design. For designers, the Symbols feature was a game changer. 

SmartObjects is the Photoshop feature most like Symbols in Sketch. They make designing easier, and 

they allow you to make nondestructive changes to an image or object. By converting your layer to a 

smart object in Photoshop, you gain much more flexibility within your design. 

Those of you who are familiar with Fireworks will recall that everything was contextual, and you 

were able to edit layers by just clicking them. The properties panel would update (like in Sketch), 

and you could get on with the business of editing that layer. Fireworks also had the ability to apply 

styles to a master page that would then govern certain styles within the document, even if they were 

spread out over a number of different pages. These are the closest features that compare to Symbols 

in Sketch. 

When designing user interfaces (UI), whether for mobile use or Web applications, there are bound to 

be many repeatable elements across screens. Menu bars, icons, and buttons are some of the most 

common of these. As designers, we go through multiple iterations of the many elements in a design. 

Being forced to change every single element would be incredibly time-consuming and inefficient. The 

Symbols feature greatly minimizes redundancies across pages and artboards in your designs. I would 

say that the Symbols feature in Sketch is closer to the Styles feature in Fireworks than it is to the 

SmartObjects feature in Photoshop. 

To understand how the Symbols feature works, it helps to take a meta look at your design. Zoom out 

so that you are able to see multiple artboards in a single view. Look for the repeatable items across 

your design. What elements appear over and over across multiple 

 
 

screens, artboards, or even pages? You will find that some objects appear on every screen. Buttons, headers, 

and tab bars are common. 

While you are able to duplicate a screen with its exact elements intact, simply duplicating an artboard or 

copying a style does not update all of the elements. How tedious would it be to have to update all of 

your icons if a client requested a slight change in color or size? 

We discussed Groups in Chapter 2 when we talked about layers. You may recall that Groups consist of a 

number of layers that can be combined based on their context. You can group layers by selecting those 

that you want to group and then selecting the Group icon from the toolbar to complete the action. You 

will see that it has been completed when the layers are combined in the Layers list with a folder icon. 

Clicking this icon will reveal all of the layers in that Group. 

http://dx.doi.org/10.1007/978-1-4842-1458-9_2
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Understanding Groups is important to understanding Symbols because Symbols are another kind of 

group of layers. Like Groups, Symbols are represented by a folder in the Layers list. 

However, the folder is purple, not blue, as shown in Figure 4-1. The image shows a group of layers, 

indicated by the blue folder, and a Symbol, indicated by the purple folder. You can also see the 

Group, Ungroup, and Symbol buttons in the toolbar. 

 

Figure 4-1. The Layers list showing a grouped set of layers, as well as a set of layers that have been made into a symbol 

 
To create a symbol, you simply select all of the layers that will make up the symbol and click the 

Create Symbol button in the toolbar. 

 

 
If you are selecting multiple individual layers, Sketch will combine them into one group and create 

the purple folder in the Layers list on the right. Now that the symbol has been created, you are free to 

use and reuse that symbol across the various pages and artboards in your designs. Note that symbols 

cannot be used across different designs in different documents. If you’d like to use that or any other 

symbols across your design, you will need to go to the Insert menu and select Symbols from the drop-

down, as shown in Figure 4-2. 

 
 

Figure 4-2. The Insert Symbols menu 
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It is also possible to create a Symbol from an already existing Group. Simply select the Group from 

the Layers list, and choose Create New Symbol from the Inspector on the right of the screen, as 

shown in Figure 4-3. The drop-down there will let you know that the currently selected layers are 

not a symbol and also show a list of the available symbols. 

Once you have created multiple symbols, you can also organize them from this menu. 

 

Figure 4-3. A list of available symbols and other symbol options 

 
If you are working on a robust design, you may find that you have created a number of symbols over 

the course of working on the design, and the number can become very large. Sketch lets you organize 

your symbols easily with a Manage Symbols option. You access this option via the Insert ➤ Symbol 

➤ Manage Symbols menu. The Manage Symbols option allows you to see a list of all of the 

symbols in your documents. You can then rename symbols or even delete them from this menu to 

keep track of them. There is also an option to organize all of your symbols from this menu. Simply 

select Organize Symbols from the Insert ➤ Symbol menu, and a window will provide you with 

options for organizing your symbols just the way that you want. The Organize Symbols window 

shown in Figure 4-4 is a  

 
 

Figure 4-4. The Organize Symbols window 

 



 Ms.R.KAVIPRIYA, DEPARTMENT OF COMPUTER APPLICATIONS
 

 

 

iOS Template Symbols 
In Chapter 2, we discussed iOS design elements templates by Teehan+Lax, which are now included 

in Sketch 3, and how they will make your life easier when designing for iOS. It is important to note 

that the majority of these UI elements have been added as symbols. With the exception of the Tab 

Bar and Background, all of the various iOS UI elements are all symbols, and they appear in the 

Layers list as purple folders. This means that as you build a page with these elements, you will also 

be able to edit and update these symbols across 

your design pages and artboards. Let’s go through the symbols and set up an artboard for a basic app 

using some symbols from the iOS template. 

Start with a new artboard from the iOS template by selecting the size of the device for which you 

are designing. I’ll choose the iPhone 6 Plus. After selecting the size of the device, Sketch will add a 

new artboard in the appropriate size onto the canvas. You can now populate it with items such as a 

map, tab bar, status bar, and so forth. These symbols can make up a basic app page, as shown in 

Figure 4-5. 

 
 

Figure 4-5. A simple UI created using symbols from the iOS template included in Sketch 3 

 

Text and Fonts 
We mentioned how symbols are linked globally across pages, artboards, and layers, so it makes sense 

http://dx.doi.org/10.1007/978-1-4842-1458-9_2
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to discuss text here since text styles work much in the same way as symbols do across pages and 

artboards. You already know that it is possible to manage multiple symbols and make changes to 

them on the fly as you iterate through your designs. Sketch also allows you to do this with text. 

Moreover, since Sketch 3 now uses the native font rendering for OS X, it means that text (especially 

text intended for the Web) looks great. But there’s a whole lot more that you can do with text in 

Sketch 3, and this makes the difference between a good design and a great design. 

Generally, typography in app design is important especially because of the limited real estate on which 

users must interact with content. While a font may look cool in your designs, you must always keep 

the user in mind. Accordingly, text in apps must remain legible at all times. It’s also a good idea to 

make sure that your font sizes don’t change from page to page. In this respect, you may want to create 

a style guide for your app before you proceed with 

the heavy lifting of the design. While creating a style guide can be tedious for designers who 

prefer to “just get on with it,” it’s a great practice and it helps to maintain a level of 

consistency—particularly when it comes to font and sizes—when handing off to other designers 

and developers alike. 

 

For those designing for the Web, Sketch comes with a preloaded template that you can select when 

creating a new document. Much like the templates for icons for iOS (iPhone & iPad), Sketch includes 

a template for those who design UIs for the Web. There’s even one for Material Design for those 

individuals who are designing for Android devices. 

When you select a UI element from the preloaded iOS App template, associated styles are included, 

like text styles. Take for instance if you wanted to select the Push notification symbol and add it to 

one of your artboards. Once you copy the symbol over to your designs, you will likely need to edit the 

copy of the notification message. To do this, you select the symbol and double-click the text fields to 

edit the content. 

As you can see in Figure 4-6, selecting a text field reveals the style associated with it in the Inspector. 

You can edit the copy in the symbol and keep the associated style. In the figure, the Style is listed as 

“Notification Content.” However, that style can be changed to any other text style in the list, or even 

to one you create on your own. In this instance, you simply need to select the copy and select a new 

style from the drop-down menu. 
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Figure 4-6. Selecting a text field highlights its associated style in the Text Inspector 

 

 

To insert text into an existing design, go to the Insert menu and select Text. This then turns your 

cursor into a text tool. Once the text tool appears, you can begin typing. Sketch will prompt you by 

inserting preformatted text on the canvas that reads “Type something,” as shown in Figure 4-7. 

Once the text box appears, you are free to begin typing. The box will
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Automatically expand to accommodate the additional text you type. What you can’t see in the figure, 

however, are the handles around the text. Like any other layer in Sketch, text on a canvas gets its very own 

box with handles. Other layers have handles on all four sides, but the text box will have three. While in 

Auto mode, you can adjust these handles easily to change the size of the text just as you would with a 

shape, image, or vector. Pulling on the handles on the left or right side of the box will expand the text box 

and make it wider. When dragged, the handle on the bottom will make the text bigger or smaller within the 

box. This is a handy way of changing font size in your text field without adjusting the numbers in the 

Inspector. 

 

Figure 4-7. The default text tool on a blank canvas 
 

Nonetheless, the text field can also be restricted by selecting the Fixed option in the Inspector to the 

right. There are a number of selections that you can make that will affect the text that you are typing 

on your canvas at that time. Currently, the text in the Figure 4-8 is set to resize the box automatically 

as you type, as the Auto button is highlighted. If the Fixed button is selected, then the size of the text 

box will be restricted and the text will wrap to fit within it. 

 
 

Figure 4-8. A closer look at the Text Inspector options for styling your text layers 
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The Text Inspector 
As with any other text editor, Sketch provides you with many ways to edit your fonts their weight, color, 

and size. When clicked, the Typeface option offers a list of all of the fonts on your computer as well as a 

preview of what each font looks like. To select one, simply click it. The weight will show the thickness or 

thinness of the font that you have selected, and there are other options, such as italics, light, bold, and 

black. 

If you’d like to create text in underline or various list types, these can be found by clicking the Options 

button next to the color picker swatch. Sketch offers double-underlined text, bulleted, and numbered lists 

as options. 

You also have the option to adjust spacing in Sketch. You can adjust the character spacing, or the space 

between each character. Line spacing refers to the amount of vertical space between multiple lines of text. 

Paragraph spacing will adjust the space that the program automatically assigns after you hit the return key 

to start a new paragraph. 
 

 

Text Alignment 
Alignment of text in Sketch is fairly straightforward, and it works mostly in the same way as in word 

processors and other graphics programs. You use the various settings to left or right-align your text, or to 

center or justify it. 

 

Text on a Path 
There are times when you will want to have your text aligned to something other than a straight line. You 

might want the text to follow a curve or a path. Sketch 3 accommodates this with the Text on a Path feature. 

First you create a vector or path that isn’t straight. You can do this using the Vector tool or even using a shape 

like an oval. After you’ve created your shape, insert a text box and add some copy. With the copy selected, 

navigate to the Type menu and select the Text on a Path option. Once you move the text box closer to the 

desired shape or path, the copy will snap to the path along the curve, as shown in Figure 4-9. 

 

Figure 4-9. Text on a Path feature using a vector and an oval drawing 
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Text Outlines 
Text Outlines is another great feature in Sketch that comes in handy when you’re looking to do 

something unique. Text cannot be manipulated the way that you manipulate shapes or to attach certain 

operations. With the Text Outlines feature in Sketch, you can get text to behave like shapes. To use this 

feature, you can add a letter or letters to your canvas as an example. With the letters selected, navigate to 

the Type menu and select the Convert Text to Outlines option. If you only typed one letter onto your 

canvas, when you convert that selection alone to a Text Outline, you will see that handles are attached to 

the letter on the screen and the Layers list will update to represent the change. What has occurred is that 

Sketch has converted the text into a shape, as shown in Figure 4-10. You are now able to edit that letter, 

just as you would any other shape. 

 

Figure 4-10. The before and after states of a text layer that has been converted to a shape using the Convert to Text Outlines feature 

 

If you choose to convert more than one letter or a number of letters using the Text Outlines feature, bear in 

mind that this can use up your computer’s resources. The reason for this is that converting long text items 

with multiple letters into vectors will require Sketch to create many small sub-paths. Creating sub-paths 

requires Sketch to calculate many Boolean operations on each letter in a string of text. If you must convert 

long text items, then it is always best to split the text into multiple layers. That way, you can convert each 

text item on separately, but even this can be taxing on your computer’s resources. 

 

Anti-Aliasing and Text 
Sketch uses the native font rendering abilities of the Mac OS and, as such, there are some instances where 

the OS has no control over the appearance of text. In these instances, it will use sub-pixel anti-aliasing to 

improve the appearance of text on a screen. This means that red, green, and blue light are added to each 

pixel. Because each pixel is actually made up of red, blue, and green sub-pixels, the idea is that when 

observed from a normal viewing distance, such as the distance between you and the computer display, your 

eyes won’t notice the colored pixels and will see the text as sharply as possible. 

Sometimes, however, sub-pixel anti-aliasing and layer blending won’t work because it needs to be drawn on 

an opaque background and rendered on a transparent background. When Sketch can’t render fonts that are 

sub-pixel anti-aliased, like on an exported PNG, you will see it clearly because the background was 

transparent and could not be rendered. 

Since, unlike the Mac OS, the iPhone does not render text with sub-pixel anti-aliasing, this presents 

some issues when designing for iOS. Since when designing your designs won’t appear on the iPhone or 

iPad in the same way that they do your computer’s screen 

(especially if you’re designing on a Retina Mac), you will need to deactivate the anti-aliasing feature in 

your designs. (It is automatically selected by default.) You can disable it by navigating to the Sketch menu, 

selecting Preferences, and deselecting the option, as shown in Figure 4-11. 
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Figure 4-11. The Preferences pane in Sketch allows you to turn off the sub-pixel anti-aliasing feature for fonts 

Text Styles 
Sketch also allows you to attach styles to text, which you can easily apply to blocks of text in your 

designs. For example, while you may have the same font in use throughout your app, you may want different 

weights and sizes in different places, such as headers, body text, and so on. This is when text styles in 

Sketch can come in handy. You can apply an unlimited number of styles to layers in your document and 

easily manage them with the Text Inspector. 

 

 
When you initially create text on the canvas, the Inspector will indicate whether or not a style has been 

attributed to the selected layer on the canvas. Usually, when adding text 

initially, there is no style. Once you add properties like color, size, case, and so forth, you can make these 

attributes into a style by selecting the drop-down in the Inspector, as shown in Figure 4-12. 

 

Figure 4-12. The Text Inspector lets you create a new text style to assign to any text layer in your document 
 

With the drop-down selected, Sketch allows you to create a new style. By default, the new style will be 

called whatever the text reads. Thus our new style here will be called “WE LOVE SKETCH Text Style,” and 

it will be highlighted so that you can edit the style. You are then able to change the name of the style to 

whatever you choose. In Figure 4-13, I’ve changed the name of the text style to “Header Text Style.” 
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Figure 4-13. The Text Inspector lets you to change the name of your style 

 

Now if you are working on a completely new layer that contains text, you will be able to go to the 

Inspector, select the style you want to assign to it, and apply it. 

You can also attribute a style to text by navigating to the Insert menu and selecting Styled Text from the 

drop-down menu, as shown in Figure 4-14. 

 

Figure 4-14. Sketch lets you select saved styles from the Insert menu as well as the Text Inspector 

 

 


